Page 1 of 1

Help! I did a very dumb thing!

Posted: 16 Jul 2019, 21:38
by dedanna1029
I tried to upgrade my old HP laptop that the wireless isn't working on from Mageia 5 to Mageia 7 by setting local resources (repos) to the rpms on the install disk to upgrade with. The problem is the upgrade (using urpmi --auto-select) stalled very quickly, so I cancelled it, and now Houston, we have a huge problem, or several. It's not seeing that urpmi is still installed from Mageia 5 for one, and I can't get the rpm command to work to get it to upgrade to the M7 version. Why did I attempt it this way? Because no matter how I set the boot order in BIOS, the thing won't boot to USB now so I can format / (root), and I was desperate to try to get the wireless working. Why this is that it won't boot to USB, I have no clue. It stopped booting to USB early on yesterday. Legacy is enabled, secure boot is not. I've also tried reloading defaults, and going from there.
My locale is effed up as well - I have this perl error whenever I try to run anything from CLI. I've tried regenerating my locale, all kinds of things I found online, but nothing fixes it.
I also have no MCC, and can't get it to install with urpmi/rpm being screwed.
Any help is very much appreciated. I'm sure I need to find my Mageia 5 disk and try downgrading back, but that will take a redownload of it. What would the command be to do this?
Thanks so much!

Re: Help! I did a very dumb thing!

Posted: 16 Jul 2019, 21:47
by dedanna1029
If you need me to, I can break each issue down to separate threads, but they all came from attempting to upgrade (not sure on the BIOS though), so, *shrug
May be best to deal with BIOS and urpmi/rpm first?

Re: Help! I did a very dumb thing!

Posted: 17 Jul 2019, 02:23
by dedanna1029
Well, I got a Mageia 5.1 disk done, and it boots to it now, but then sits there at a blank screen with a blinking cursor. :-P

Re: Help! I did a very dumb thing!

Posted: 08 Aug 2019, 14:09
by viking60
Maybe try to start the X server?

Re: Help! I did a very dumb thing!

Posted: 09 Aug 2019, 09:31
by Blackcrack
urpmi --auto-select was okey so far, but , never try to stop a update ...*g*

important questions:
  • do you have a root login ? [important]
  • urpmi.. okey.. do you have a connect to the internet ? [important]
  • did you try "urpmi task-kde task-kde-minimal"
  • did you try "urpmi task-gnome "


best regards

Re: Help! I did a very dumb thing!

Posted: 25 Aug 2019, 19:10
by dedanna1029
I don't have a connection on the thing, Blackie, was using the dvd on usb.
Viking, I have x server. The problem, is that I can't get a full install done because the computer won't boot to usb. I can't get past the bios screen when I try.

I think I'm going to scrap Mageia and try Fedora on this thing. I think it's a more updated distro, and probably covers more hardware. It may find my wireless chip.