Mageia 5

Well it is a family: Mandriva Mageia ROSA Unity PCLOS. Brothers and sisters living together in perfect harmony - so it deserved som space of its own.

Moderators: b1o, jkerr82508

User avatar
viking60
Über-Berserk
Posts: 9320
Joined: 14 Mar 2010, 16:34

Re: Mageia 5

Postby viking60 » 08 Oct 2015, 08:51

It is time to install cygwin.
From there you can "wget" what you want.

Install all of it! It is a big package but then you get a Linux cli in Windows. with ssh wget - maybe curl etc.
Manjaro 64bit on the main box -Intel(R) Core(TM) i7 CPU 920 @ 2.67GHz and nVidia Corporation GT200b [GeForce GTX 275] (rev a1. + Centos on the server - Arch on the laptop.
"There are no stupid questions - Only stupid answers!"

User avatar
dedanna1029
Sound-Berserk
Posts: 8621
Joined: 14 Mar 2010, 20:29
Contact:

Re: Mageia 5

Postby dedanna1029 » 08 Oct 2015, 21:42

Oooooohhh, good one! I'd forgotten about that - will get to it tonight!

Update: (It's "tonight" right now) You betcha I'm getting all of it! Time to play play play with more than just wget lol! :) I just wish I could do Cygwin/X, but it only goes to Win7 now from what they say at the site. I'm on 8.1.
I'd rather be a free person who fears terrorists, than be a "safe" person who fears the government.
No gods, no masters.
"A druid is by nature anarchistic, that is, submits to no one."
http://uk.druidcollege.org/faqs.html

User avatar
dedanna1029
Sound-Berserk
Posts: 8621
Joined: 14 Mar 2010, 20:29
Contact:

Re: Mageia 5

Postby dedanna1029 » 11 Nov 2015, 16:12

I'm hoping Jim will see this. I'm having issues with updates in Mageia. First off, for the libreoffice update, it wants me to install a language pack other than my own. The closest would be the UK one, which I don't have a problem using except... it's using en right now:

Code: Select all

[dedanna@localhost ~]$ rpm -qa | grep libreoffice
libreoffice-calc-4.4.2.2-4.mga5
libreoffice-impress-4.4.2.2-4.mga5
libreoffice-pyuno-4.4.2.2-4.mga5
libreoffice-graphicfilter-4.4.2.2-4.mga5
libreoffice-emailmerge-4.4.2.2-4.mga5
libreoffice-draw-4.4.2.2-4.mga5
libreoffice-core-4.4.2.2-4.mga5
libreoffice-kde-4.4.2.2-4.mga5
libreoffice-ogltrans-4.4.2.2-4.mga5
libreoffice-opensymbol-fonts-4.4.2.2-4.mga5
libreoffice-pdfimport-4.4.2.2-4.mga5
libreoffice-langpack-en-4.4.2.2-4.mga5
libreoffice-math-4.4.2.2-4.mga5
libreoffice-base-4.4.2.2-4.mga5
libreoffice-writer-4.4.2.2-4.mga5
libreoffice-ure-4.4.2.2-4.mga5
libreoffice-xsltfilter-4.4.2.2-4.mga5
libreoffice-wiki-publisher-4.4.2.2-4.mga5
[dedanna@localhost ~]$


At first I thought this was funny, but then followed it through. I told it UK, and then it asked for the same thing again.
I chose UK again, and up popped this:

Code: Select all

The following packages have to be removed for others to be upgraded:
libreoffice-base-4.4.2.2-4.mga5.x86_64
 (due to missing libfwelo.so()(64bit),
  due to missing libsotlo.so()(64bit),
  due to missing libi18nlangtag.so()(64bit),
  due to missing libeditenglo.so()(64bit),
  due to missing libsvxlo.so()(64bit),
  due to missing libtklo.so()(64bit),
  due to missing libxolo.so()(64bit),
  due to missing libucbhelper.so()(64bit),
  due to missing libcomphelper.so()(64bit),
  due to missing libsaxlo.so()(64bit),
  due to missing libdbtoolslo.so()(64bit),
  due to missing libsvtlo.so()(64bit),
  due to unsatisfied libreoffice-core == 4.4.2.2-4.mga5,
  due to missing libdbulo.so()(64bit),
  due to missing libsfxlo.so()(64bit),
  due to missing libutllo.so()(64bit),
  due to missing libsvxcorelo.so()(64bit),
  due to missing libtllo.so()(64bit),
  due to missing libvcllo.so()(64bit),
  due to missing libsvllo.so()(64bit),
  due to missing libforlo.so()(64bit),
  due to missing libforuilo.so()(64bit),
  due to unsatisfied libreoffice-calc == 4.4.2.2-4.mga5,
  due to unsatisfied libreoffice-pyuno == 4.4.2.2-4.mga5)
libreoffice-calc-4.4.2.2-4.mga5.x86_64
 (due to missing libdrawinglayerlo.so()(64bit),
  due to missing libwriterperfectlo.so()(64bit),
  due to missing libsotlo.so()(64bit),
  due to missing libooxlo.so()(64bit),
  due to missing libi18nlangtag.so()(64bit),
  due to missing libvbahelperlo.so()(64bit),
  due to missing libeditenglo.so()(64bit),
  due to missing libsvxlo.so()(64bit),
  due to missing libtklo.so()(64bit),
  due to missing libxolo.so()(64bit),
  due to missing libucbhelper.so()(64bit),
  due to missing libfilelo.so()(64bit),
  due to missing libcomphelper.so()(64bit),
  due to missing libbasegfxlo.so()(64bit),
  due to missing libsaxlo.so()(64bit),
  due to missing libdbtoolslo.so()(64bit),
  due to missing libconfigmgrlo.so()(64bit),
  due to missing libmsfilterlo.so()(64bit),
  due to missing libavmedialo.so()(64bit),
  due to missing libsvtlo.so()(64bit),
  due to unsatisfied libreoffice-core == 4.4.2.2-4.mga5,
  due to missing libi18nutil.so()(64bit),
  due to missing libsblo.so()(64bit),
  due to missing libsfxlo.so()(64bit),
  due to missing libutllo.so()(64bit),
  due to missing libsvxcorelo.so()(64bit),
  due to missing libtllo.so()(64bit),
  due to missing libvcllo.so()(64bit),
  due to missing libsvllo.so()(64bit),
  due to unsatisfied libreoffice-pyuno == 4.4.2.2-4.mga5)
libreoffice-core-4.4.2.2-4.mga5.x86_64
 (due to unsatisfied libreoffice-opensymbol-fonts == 4.4.2.2-4.mga5,
  due to missing libopencllo.so()(64bit),
  due to missing libclewlo.so()(64bit))
libreoffice-draw-4.4.2.2-4.mga5.x86_64
 (due to unsatisfied libreoffice-core == 4.4.2.2-4.mga5,
  due to unsatisfied libreoffice-graphicfilter == 4.4.2.2-4.mga5,
  due to unsatisfied libreoffice-pdfimport == 4.4.2.2-4.mga5,
  due to unsatisfied libreoffice-pyuno == 4.4.2.2-4.mga5)
libreoffice-emailmerge-4.4.2.2-4.mga5.x86_64
 (due to unsatisfied libreoffice-writer == 4.4.2.2-4.mga5,
  due to unsatisfied libreoffice-pyuno == 4.4.2.2-4.mga5)
libreoffice-graphicfilter-4.4.2.2-4.mga5.x86_64
 (due to missing libwriterperfectlo.so()(64bit),
  due to missing libsotlo.so()(64bit),
  due to missing libi18nlangtag.so()(64bit),
  due to missing libeditenglo.so()(64bit),
  due to missing libtklo.so()(64bit),
  due to missing libxolo.so()(64bit),
  due to missing libcomphelper.so()(64bit),
  due to missing libbasegfxlo.so()(64bit),
  due to missing libsaxlo.so()(64bit),
  due to missing libsvtlo.so()(64bit),
  due to unsatisfied libreoffice-core == 4.4.2.2-4.mga5,
  due to missing libsfxlo.so()(64bit),
  due to missing libutllo.so()(64bit),
  due to missing libsvxcorelo.so()(64bit),
  due to missing libtllo.so()(64bit),
  due to missing libvcllo.so()(64bit),
  due to missing libsvllo.so()(64bit))
libreoffice-impress-4.4.2.2-4.mga5.x86_64
 (due to missing libwriterperfectlo.so()(64bit),
  due to missing libsotlo.so()(64bit),
  due to missing libxolo.so()(64bit),
  due to missing libucbhelper.so()(64bit),
  due to missing libcomphelper.so()(64bit),
  due to missing libsaxlo.so()(64bit),
  due to unsatisfied libreoffice-core == 4.4.2.2-4.mga5,
  due to missing libutllo.so()(64bit),
  due to missing libtllo.so()(64bit),
  due to missing libvcllo.so()(64bit),
  due to unsatisfied libreoffice-ogltrans == 4.4.2.2-4.mga5,
  due to unsatisfied libreoffice-pyuno == 4.4.2.2-4.mga5)
libreoffice-kde-4.4.2.2-4.mga5.x86_64
 (due to missing libsotlo.so()(64bit),
  due to missing libi18nlangtag.so()(64bit),
  due to missing libucbhelper.so()(64bit),
  due to missing libvclplug_genlo.so()(64bit),
  due to missing libcomphelper.so()(64bit),
  due to missing libbasegfxlo.so()(64bit),
  due to unsatisfied libreoffice-core == 4.4.2.2-4.mga5,
  due to missing libi18nutil.so()(64bit),
  due to missing libutllo.so()(64bit),
  due to missing libtllo.so()(64bit),
  due to missing libvcllo.so()(64bit))
libreoffice-langpack-en-4.4.2.2-4.mga5.x86_64
 (due to unsatisfied libreoffice-core == 4.4.2.2-4.mga5)
libreoffice-math-4.4.2.2-4.mga5.x86_64
 (due to missing libsotlo.so()(64bit),
  due to missing libooxlo.so()(64bit),
  due to missing libi18nlangtag.so()(64bit),
  due to missing libeditenglo.so()(64bit),
  due to missing libsvxlo.so()(64bit),
  due to missing libtklo.so()(64bit),
  due to missing libxolo.so()(64bit),
  due to missing libcomphelper.so()(64bit),
  due to missing libsaxlo.so()(64bit),
  due to missing libmsfilterlo.so()(64bit),
  due to missing libsvtlo.so()(64bit),
  due to unsatisfied libreoffice-core == 4.4.2.2-4.mga5,
  due to missing libi18nutil.so()(64bit),
  due to missing libsfxlo.so()(64bit),
  due to missing libutllo.so()(64bit),
  due to missing libsvxcorelo.so()(64bit),
  due to missing libtllo.so()(64bit),
  due to missing libvcllo.so()(64bit),
  due to missing libsvllo.so()(64bit),
  due to unsatisfied libreoffice-pyuno == 4.4.2.2-4.mga5)
libreoffice-ogltrans-4.4.2.2-4.mga5.x86_64
 (due to missing libcomphelper.so()(64bit),
  due to missing libbasegfxlo.so()(64bit),
  due to missing libcanvastoolslo.so()(64bit),
  due to missing libvcllo.so()(64bit),
  due to unsatisfied libreoffice-impress == 4.4.2.2-4.mga5)
libreoffice-pdfimport-4.4.2.2-4.mga5.x86_64
 (due to missing libbasegfxlo.so()(64bit),
  due to missing libreoffice-core[*],
  due to missing libvcllo.so()(64bit),
  due to unsatisfied libreoffice-draw == 4.4.2.2-4.mga5)
libreoffice-pyuno-4.4.2.2-4.mga5.x86_64
 (due to missing libreoffice-core[*],
  due to unsatisfied libreoffice-core == 4.4.2.2-4.mga5)
libreoffice-wiki-publisher-4.4.2.2-4.mga5.x86_64
 (due to missing libreoffice-core[*],
  due to unsatisfied libreoffice-writer == 4.4.2.2-4.mga5)
libreoffice-writer-4.4.2.2-4.mga5.x86_64
 (due to missing libwriterperfectlo.so()(64bit),
  due to missing libsotlo.so()(64bit),
  due to missing libooxlo.so()(64bit),
  due to missing libi18nlangtag.so()(64bit),
  due to missing libvbahelperlo.so()(64bit),
  due to missing libeditenglo.so()(64bit),
  due to missing libsvxlo.so()(64bit),
  due to missing libtklo.so()(64bit),
  due to missing libxolo.so()(64bit),
  due to missing libucbhelper.so()(64bit),
  due to missing libcomphelper.so()(64bit),
  due to missing libswlo.so()(64bit),
  due to missing libbasegfxlo.so()(64bit),
  due to missing libsaxlo.so()(64bit),
  due to missing libmsfilterlo.so()(64bit),
  due to missing libsvtlo.so()(64bit),
  due to unsatisfied libreoffice-core == 4.4.2.2-4.mga5,
  due to missing libi18nutil.so()(64bit),
  due to missing libsblo.so()(64bit),
  due to missing libsfxlo.so()(64bit),
  due to missing libutllo.so()(64bit),
  due to missing libsvxcorelo.so()(64bit),
  due to missing libtllo.so()(64bit),
  due to missing libvcllo.so()(64bit),
  due to missing libsvllo.so()(64bit),
  due to unsatisfied libreoffice-pyuno == 4.4.2.2-4.mga5)
libreoffice-xsltfilter-4.4.2.2-4.mga5.x86_64
 (due to unsatisfied libreoffice-core == 4.4.2.2-4.mga5)
wesnoth-1.12.4-1.mga5.x86_64
 (due to unsatisfied wesnoth-data == 1.12.4)


Re: wesnoth-data, it's installed. I don't understand that one. I honestly don't understand the other conflicts either. Can you enlighten me please? Or do I need to file a bug?

Thanks.

Edit: Never mind, the mirrors hadn't synced yet.
I'd rather be a free person who fears terrorists, than be a "safe" person who fears the government.
No gods, no masters.
"A druid is by nature anarchistic, that is, submits to no one."
http://uk.druidcollege.org/faqs.html

jkerr82508
Guru-Berserk
Posts: 209
Joined: 16 Oct 2010, 21:45
Location: Fife, Scotland

Re: Mageia 5

Postby jkerr82508 » 11 Nov 2015, 20:20

libreoffice-langpack-uk is Ukrainian language support. For all English language installations use libreoffice-langpack-en and then select the English variant in Tools - Options - Language Settings.

An update to libreoffice has just been released. http://advisories.mageia.org/MGASA-2015-0441.html
Perhaps your mirror had not fully sync'd.

Jim

User avatar
dedanna1029
Sound-Berserk
Posts: 8621
Joined: 14 Mar 2010, 20:29
Contact:

Re: Mageia 5

Postby dedanna1029 » 11 Nov 2015, 20:32

Sorry, couldn't get back here. I kept telling it no and waited. Finally got the updates in correctly. Thanks!
I'd rather be a free person who fears terrorists, than be a "safe" person who fears the government.
No gods, no masters.
"A druid is by nature anarchistic, that is, submits to no one."
http://uk.druidcollege.org/faqs.html

User avatar
dedanna1029
Sound-Berserk
Posts: 8621
Joined: 14 Mar 2010, 20:29
Contact:

Re: Mageia 5

Postby dedanna1029 » 12 Nov 2015, 03:14

Updates have been stragging in here and there all day. I changed the downloader to wget - aria2 was being really slow and sending me updates from China, nowhere near me so I chose a Europe mirror, and also kept getting an error on the Nonfree repo. Once I did that, the updates did the same, straggled in all day, and I kept getting an error on updating urpmi sources:

Code: Select all

[root@localhost ~]# urpmi.update -a   
medium "Core Release (distrib1)" is up-to-date
medium "Nonfree Release (distrib11)" is up-to-date
medium "Nonfree Updates (distrib13)" is up-to-date
--->...retrieving failed: wget failed: exited with 8<---

medium "Core 32bit Updates (distrib32)" is up-to-date
medium "Nonfree 32bit Release (distrib36)" is up-to-date
medium "Nonfree 32bit Updates (distrib37)" is up-to-date
medium "google-chrome" is up-to-date
medium "google-earth" is up-to-date
medium "google-music" is up-to-date
medium "google-talkplugin" is up-to-date
medium "Core Release (distrib46)" is up-to-date
medium "Core Updates (distrib48)" is up-to-date
medium "Nonfree Release (distrib56)" is up-to-date
medium "Nonfree Updates (distrib58)" is up-to-date
medium "Tainted Release (distrib66)" is up-to-date
medium "Tainted Updates (distrib68)" is up-to-date
medium "Core 32bit Release (distrib76)" is up-to-date
medium "Core 32bit Updates (distrib77)" is up-to-date
medium "Nonfree 32bit Release (distrib81)" is up-to-date
medium "Nonfree 32bit Updates (distrib82)" is up-to-date
medium "Tainted 32bit Release (distrib86)" is up-to-date
medium "Tainted 32bit Updates (distrib87)" is up-to-date
medium "Core Release (distrib91)" is up-to-date
medium "Core Updates (distrib93)" is up-to-date
medium "Nonfree Release (distrib101)" is up-to-date
medium "Nonfree Updates (distrib103)" is up-to-date
medium "Tainted Release (distrib111)" is up-to-date
medium "Tainted Updates (distrib113)" is up-to-date
medium "Core 32bit Release (distrib121)" is up-to-date
medium "Core 32bit Updates (distrib122)" is up-to-date
medium "Nonfree 32bit Release (distrib126)" is up-to-date
medium "Nonfree 32bit Updates (distrib127)" is up-to-date
medium "Tainted 32bit Release (distrib131)" is up-to-date
medium "Tainted 32bit Updates (distrib132)" is up-to-date
medium "Core Release (distrib136)" is up-to-date
medium "Core Updates (distrib138)" is up-to-date
medium "Nonfree Release (distrib146)" is up-to-date
medium "Nonfree Updates (distrib148)" is up-to-date
medium "Tainted Release (distrib156)" is up-to-date
medium "Tainted Updates (distrib158)" is up-to-date
medium "Core 32bit Release (distrib166)" is up-to-date
medium "Core 32bit Updates (distrib167)" is up-to-date
medium "Nonfree 32bit Release (distrib171)" is up-to-date
medium "Nonfree 32bit Updates (distrib172)" is up-to-date
medium "Tainted 32bit Release (distrib176)" is up-to-date
medium "Tainted 32bit Updates (distrib177)" is up-to-date
[root@localhost ~]#

I got the same error in the same place with aria2 at the exact same point. I changed the mirror to another one for wget. Same thing.

I'm going to assume there's issues with the Nonfree Updates repo on Mageia's end, or am I not correct in this? I've been getting that error in the same spot all day no matter how I set up urpmi with repos.

Thanks.
I'd rather be a free person who fears terrorists, than be a "safe" person who fears the government.
No gods, no masters.
"A druid is by nature anarchistic, that is, submits to no one."
http://uk.druidcollege.org/faqs.html

jkerr82508
Guru-Berserk
Posts: 209
Joined: 16 Oct 2010, 21:45
Location: Fife, Scotland

Re: Mageia 5

Postby jkerr82508 » 12 Nov 2015, 04:41

There is no problem at Mageia, but here were a large number of updates released over the last couple of days:
http://advisories.mageia.org/5.html

You seem to have multiple mirrors defined. I recommend that you remove all of your sources and use kernel.org as your only mirror.

You can check the status of your chosen mirror(s):
http://mirrors.mageia.org/status

Jim

User avatar
dedanna1029
Sound-Berserk
Posts: 8621
Joined: 14 Mar 2010, 20:29
Contact:

Re: Mageia 5

Postby dedanna1029 » 12 Nov 2015, 15:45

Yeah, I got that. The multiple mirrors probably defined when I kept adding another one because one wouldn't work. I've disabled the extras since and dropped it to kernel.org as you said. Same thing.

I ran a search for the error and there were different reasons for it. With most it resolved itself.

Update: However here it hasn't. Just checked.
Last edited by dedanna1029 on 12 Nov 2015, 15:56, edited 1 time in total.
I'd rather be a free person who fears terrorists, than be a "safe" person who fears the government.
No gods, no masters.
"A druid is by nature anarchistic, that is, submits to no one."
http://uk.druidcollege.org/faqs.html

User avatar
dedanna1029
Sound-Berserk
Posts: 8621
Joined: 14 Mar 2010, 20:29
Contact:

Re: Mageia 5

Postby dedanna1029 » 12 Nov 2015, 15:55

Removing them got it.
What's the difference between removing them all and disabling extra ones? It would seem that disabling the extras would've done it too.
I'd rather be a free person who fears terrorists, than be a "safe" person who fears the government.
No gods, no masters.
"A druid is by nature anarchistic, that is, submits to no one."
http://uk.druidcollege.org/faqs.html

User avatar
dedanna1029
Sound-Berserk
Posts: 8621
Joined: 14 Mar 2010, 20:29
Contact:

Re: Mageia 5 - WHOA.

Postby dedanna1029 » 13 Jan 2016, 00:50

:wrf

Code: Select all

[root@localhost ~]# urpmi --auto-update
medium "Core Release (distrib1)" is up-to-date
medium "Core Updates (distrib3)" is up-to-date
medium "Nonfree Release (distrib11)" is up-to-date
medium "Nonfree Updates (distrib13)" is up-to-date
medium "Core 32bit Release (distrib31)" is up-to-date
medium "Core 32bit Updates (distrib32)" is up-to-date
medium "Nonfree 32bit Release (distrib36)" is up-to-date
medium "Nonfree 32bit Updates (distrib37)" is up-to-date
error: rpmdb: BDB0113 Thread/process 22745/140050801891072 failed: BDB1507 Thread died in Berkeley DB library
error: db5 error(-30973) from dbenv->failchk: BDB0087 DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db5 -  (-30973)
error: cannot open Packages database in /var/lib/rpm
unable to open rpmdb
[root@localhost ~]#

Like, wow... I don't think I'll ask for help on it. I'm just alerting others. I am going to try rebuilding the rpm db. I have never seen this. Never.

Edit: Yup, that got it.
I'd rather be a free person who fears terrorists, than be a "safe" person who fears the government.
No gods, no masters.
"A druid is by nature anarchistic, that is, submits to no one."
http://uk.druidcollege.org/faqs.html

User avatar
viking60
Über-Berserk
Posts: 9320
Joined: 14 Mar 2010, 16:34

Re: Mageia 5

Postby viking60 » 13 Jan 2016, 16:45

Good thing that you have lots of experience with it. I think have seen it before but it mostly was my fault for playing around with it.

Not good for greenhorns though....
Manjaro 64bit on the main box -Intel(R) Core(TM) i7 CPU 920 @ 2.67GHz and nVidia Corporation GT200b [GeForce GTX 275] (rev a1. + Centos on the server - Arch on the laptop.
"There are no stupid questions - Only stupid answers!"

User avatar
dedanna1029
Sound-Berserk
Posts: 8621
Joined: 14 Mar 2010, 20:29
Contact:

Re: Mageia 5

Postby dedanna1029 » 14 Jan 2016, 01:31

Well, I have no clue about the output on that. I did see where it said to recover the db though in the code, so looked up to refresh how to rebuild the rpm db, and went for it.
I'm just glad it worked.

You're right - not good for greenhorns, and I have absolutely no clue what caused it.
I'd rather be a free person who fears terrorists, than be a "safe" person who fears the government.
No gods, no masters.
"A druid is by nature anarchistic, that is, submits to no one."
http://uk.druidcollege.org/faqs.html


Return to “The Mandriva family”