Watchdog did not stop/start

Every day solutions to every day challenges. + Brilliant stuff

Moderators: b1o, jkerr82508

Forum rules
Please feel free to post your tip it does not have to be advanced. Also ask questions directly related to the tip here. But do not start new threads with questions or ask for help here. That is what the help section is for. forum rules: http://bjoernvold.com/forum/viewtopic.php?f=8&t=568
User avatar
viking60
Über-Berserk
Posts: 9285
Joined: 14 Mar 2010, 16:34

Watchdog did not stop/start

Postby viking60 » 16 Nov 2018, 13:03

I have been allerted regarding watchdog a lot during my Linux days. Mostly I get that watchdog did not stop during shutdown ...or it did not start during boot.

It has no particular effect and the shutdowns and boots went just fine regardless of that annoying message,

So what does that annoying watchdog do and can I please kill it ?

Well the watchdog does keep watch om mission critical computers:

A watchdog timer [...] is an electronic timer that is used to detect and recover from computer malfunctions. During normal operation, the computer regularly resets the watchdog timer [...]. If, [...], the computer fails to reset the watchdog, the timer will elapse and generate a timeout signal [...] used to initiate corrective [...] actions [...] typically include placing the computer system in a safe state and restoring normal system operation.
Many users need this feature due to their system's mission-critical role (i.e. servers), or because of the lack of power reset (i.e. embedded devices). Thus, this feature is required for a good operation in some situations. On the other hand, normal users (i.e. desktop and laptop) do not need this feature and can disable it.

..and I don't need it on my laptop! :jackpot

Time to kill this dog then:
First I checked if the watchdog was indeed active on my system with:

Code: Select all

cat /proc/sys/kernel/watchdog

If it returns "1" then it is active (...this will be the case on most systems).

I then edited /etc/default/grub like this

Code: Select all

sudo nano /etc/default/grub
and added nowatchdog to the GRUB cmdline:

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nowatchdog"

simply by adding a space and nowatchdog to the end of the line.

Then I made it persistent by re-generating grub.cfg file like this:

Code: Select all

sudo grub-mkconfig -o /boot/grub/grub.cfg


Rebooted and the watchdog was gone!
:A

Code: Select all

cat /proc/sys/kernel/watchdog
0

If you want to check this first before making it permanent you can simply hit e during boot and add nowatchdog to the end of your linux line.
This will disable it for one boot but not be permanent.

That is it you have killed your watchdog! ..And your system will boot faster because there is one less module to be loaded.
Manjaro 64bit on the main box -Intel(R) Core(TM) i7 CPU 920 @ 2.67GHz and nVidia Corporation GT200b [GeForce GTX 275] (rev a1. + Centos on the server - Arch on the laptop.
"There are no stupid questions - Only stupid answers!"

netEmma
Posts: 19
Joined: 07 May 2019, 14:19

Re: Watchdog did not stop/start

Postby netEmma » 21 May 2019, 08:28

he did stat or stop


Return to “Tips & Tricks”