Page 1 of 1

Canon LBP7110Cw Setup

Posted: 31 Mar 2018, 21:28
by R_Head
Trying to set up a Canon LBP7110Cw on Mageia 6, the Driver List is limited and nothing seems to work. The Printer shows on the network but is major driver issue. I am about to the end of my rope.

Any ideas, suggestions are very much welcome :)

Re: Canon LBP7110Cw Setup

Posted: 01 Apr 2018, 09:54
by viking60
I finally got a Brother Laser printer to work with scanner and all (on Mandriva).
I tried all the complicated stuff but in the end it was simply to wait for a Kernel update that helped.
You could check if the commputer works with some live CD from another Distro and check out what kernel is used.

I finally switched from Mandriva to Manjaro mainly due to driver issues (on that ladies computer).

Re: Canon LBP7110Cw Setup

Posted: 01 Apr 2018, 15:09
by R_Head
Found a link in the Mageia Forum. Long story short, led me to search at the Canon website, lo an behold, they have a RPM for the printer. ... %20(64-bit)

Untared the file, ran the 3 RPMs that came with it, and works like a champ. What is odd is, on my laptops, seems not to work directly with the x86 RPMs. I enabled the sharing on my Dell 64 system and use it as a print server. One laptop refuses to connect in any way, however, that one, is not a big deal.

is a nice Color Laser printer, the wife paid $125 new from Staples. Also, the neat thing is that has a Wireless NIC, RJ45 and USB. Setup as Wireless, and all you have to plug it for power. The Wireless setup is not that easy, took me a while to get that bad boy going.

Re: Canon LBP7110Cw Setup

Posted: 02 Apr 2018, 17:26
by R_Head
Problem Fixed.... +1

Made the mistake on using the 32 Bit RPM. Removed the packages with the MCC. Installed the 64Bit RPMs on both laptops. Now it works like a champ. :dance: :cheers

Used the MCC Add Printer setup/GUI, worked very nicely :mrgreen:

Re: Canon LBP7110Cw Setup

Posted: 02 Apr 2018, 21:34
by viking60
love it when a problem gets solved :s