ata2:COMRESET failed

Hardware tips and talk

Moderators: b1o, jkerr82508

User avatar
viking60
Über-Berserk
Posts: 9279
Joined: 14 Mar 2010, 16:34

ata2:COMRESET failed

Postby viking60 » 07 Jun 2017, 11:10

After an update I got a loong pause in boot and repeated message

Code: Select all

ata2: COMRESET failed errno=16

Now this usually means that the disk is fubared and this Lenovo Ideapad 110 is brand new :f

I did a

Code: Select all

dmesg | grep ata2
and it indicated four attempts before giving up.

Now the boot did go through - eventually - but it is no good feeling so I "DuckDuckGoed" a bit and found that this does indicate HD/SSD trouble and that there have been issues with the kernel....years ago. :tux5:
So I am pretty much left with a moody disk system.

Updating SSD firmware and indeed all my firmware could help - but How on earth do we do that?

It can be done in Linux - I have heard - but it would implicate me standing on my head and doing double somersaults.
Then I got the idea to put Windows 10 to use. :idea:

I was betting on the "control everything urge" and true enough I did have something called Lenovo bridge running.
I never understood why it was running and how it works but now I found out.

When entering the Lenovo support site you can pick update drivers and firmware in the Browser and if you do not know what to pick (picking the wrong ones is definitely not a good idea ) then you can log in with Google or Win ID (or other spying services that know all about you and your computer) and scan what updates you need.

Lenovo Bridge does provide the data for the scan - so now I know.

Leave the browser open while the process runs and your firmware and drivers will be updated and don't use Edge - Lenovo discourages it - use Firefox.

So I left it scanning and went to bed. The next morning I rebooted (Into Linux of course) and the error message was gone! :dance:

Problem fixed but don't ask me how it occurred in the first place (.. eh well you could.... and I would answer that the firmware was not state of the art...)
Manjaro 64bit on the main box -Intel(R) Core(TM) i7 CPU 920 @ 2.67GHz and nVidia Corporation GT200b [GeForce GTX 275] (rev a1. + Centos on the server - Arch on the laptop.
"There are no stupid questions - Only stupid answers!"

Return to “Hardware”