Wireless issue (AGAIN), Mageia 5

Need help with your Linux distro? All questions are good - not all answers are -but we try

Moderator: jkerr82508

User avatar
viking60
Über-Berserk
Posts: 9280
Joined: 14 Mar 2010, 16:34

Re: Wireless issue (AGAIN), Mageia 5

Postby viking60 » 21 Mar 2016, 10:58

Image
Must be Dr Stadler or Dr Walldorf :lol:

He is making an effort there though -so be nice :-D (I think you were surprisingly nice there so no complaints there but not so nice here so I have to defend him )

He's stands on firm ground with his disclaimer:
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts


Let's just stick with the issue...Which I probably will be totally incapable to help you with :-D
Manjaro 64bit on the main box -Intel(R) Core(TM) i7 CPU 920 @ 2.67GHz and nVidia Corporation GT200b [GeForce GTX 275] (rev a1. + Centos on the server - Arch on the laptop.
"There are no stupid questions - Only stupid answers!"

User avatar
dedanna1029
Sound-Berserk
Posts: 8483
Joined: 14 Mar 2010, 20:29
Contact:

Re: Wireless issue (AGAIN), Mageia 5

Postby dedanna1029 » 22 Mar 2016, 01:54

Nah, I don't think you are. It's why I asked here. :)
I'm sorry, I still haven't been able to work on the issue. I need to get a day when I can go to the library with both my tablet and laptop in hand, which isn't easy to do in my situation. *sigh

I also think R_Head was quite nice in his thread there, btw. If you notice, most are.
Evidently "nice" isn't appreciated there. With that, I'll drop it. The reason I brought it up was to compare help methods, what works, and what doesn't. Know-it-alls who honestly don't have a clue (in particular R_Head's and my requests for help), well, their methods don't work. At all.
I'd rather be a free person who fears terrorists, than be a "safe" person who fears the government.
No gods, no masters.
"A druid is by nature anarchistic, that is, submits to no one."
http://uk.druidcollege.org/faqs.html

User avatar
dedanna1029
Sound-Berserk
Posts: 8483
Joined: 14 Mar 2010, 20:29
Contact:

Re: Wireless issue (AGAIN), Mageia 5

Postby dedanna1029 » 23 Mar 2016, 20:20

OK, here's the deal:
It now sees the device, but when I try to set up a wireless connection, I still get the same error as in the OP.
I ran "rfkill list" as root, and it's showing it as hard blocked. Indeed, the wireless light is amber, but the issue is when I tap the light I get no response.
I'm tempted to run "rfkill unblock all" but for some reason I have a feeling I'd screw something doing it.
The wireless device on this is on by factory default.
I'm researching "hp compaq wireless hard block" now via Google search, the first result, a thread, doesn't seem to apply. I'm still looking though.

Suggestions?

Thanks. :)
I'd rather be a free person who fears terrorists, than be a "safe" person who fears the government.
No gods, no masters.
"A druid is by nature anarchistic, that is, submits to no one."
http://uk.druidcollege.org/faqs.html

User avatar
dedanna1029
Sound-Berserk
Posts: 8483
Joined: 14 Mar 2010, 20:29
Contact:

Re: Wireless issue (AGAIN), Mageia 5

Postby dedanna1029 » 23 Mar 2016, 22:10

An output you requested. viking:

Code: Select all

lspci | egrep -i --color 'network|ethernet'
02:00.0 Ethernet controller: Broadcom Corporation Netlink BCM5787M Gigabit Ethernet PCI Express (rev 02)
09:00.0 Network Controller: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller (rev 01)


Code: Select all

rfkill list all
0: hp-wifi: Wireless LAN
Soft blocked: no
Hard blocked: yes
1: hp-gps: GPSSoft blocked: yes
hard blocked: yes

There is also a line when I run lsmod:

Code: Select all

rfkill                                        22677  2 cfg80211,hp_wmi

and another:

Code: Select all

cfg80211                               534762  1 wl




I'm having to type outputs manually into here, so please assume all is as root until said otherwise.

Thanks!
I'd rather be a free person who fears terrorists, than be a "safe" person who fears the government.
No gods, no masters.
"A druid is by nature anarchistic, that is, submits to no one."
http://uk.druidcollege.org/faqs.html

User avatar
viking60
Über-Berserk
Posts: 9280
Joined: 14 Mar 2010, 16:34

Re: Wireless issue (AGAIN), Mageia 5

Postby viking60 » 24 Mar 2016, 12:34

So assumed... having a look...

Broadcom BCM43142 https://forums.mageia.org/en/viewtopic.php?f=25&t=7211
Broadcom BCM4313 ( vendor:14e4 device:4727 ) - wpa_supplicant segfaults when using net_applet with wl driver during AP connection, or times out during authentication with brcmsmac
after switching to networkmanager kernel panic and complete lockup with wl driver, but connection should work fine with brcmsmac driver https://forums.mageia.org/de/viewtopic.php?f=18&t=2373
Broadcom b43 + openfwwf vs. propr. wl driver http://archive.openmandriva.org/wiki/en ... b43_driver and http://wireless.kernel.org/en/users/Dri ... en_drivers or maybe https://forums.mageia.org/en/viewtopic.php?f=25&t=2329
some Broadcom drivers, in combination with atl1c wired driver leads to conflicts. Workaround is to blacklist the atl1c driver by e.g. as root echo "blacklist atl1c" >> /etc/modprobe.d/blacklist-mga.conf https://bugs.mageia.org/show_bug.cgi?id=5087


Your specific Broadcom wireless is not mentioned (BCM4322) so we must go for the general broadcom fix:

According to the above that would be to do a (as root):

Code: Select all

echo "blacklist atl1c" >> /etc/modprobe.d/blacklist-mga.conf


That atl1c thing is for the wired net and somehow could interrupt your wireless connection. Broadcom seems to be a bad thing for open source....

The good news is that the laptop PCI express cards probably will work according to this

Worth a try - I guess you can always remove blacklist atl1c from your /etc/modprobe.d/blacklist-mga.conf later if it does not work.
Manjaro 64bit on the main box -Intel(R) Core(TM) i7 CPU 920 @ 2.67GHz and nVidia Corporation GT200b [GeForce GTX 275] (rev a1. + Centos on the server - Arch on the laptop.
"There are no stupid questions - Only stupid answers!"

User avatar
dedanna1029
Sound-Berserk
Posts: 8483
Joined: 14 Mar 2010, 20:29
Contact:

Re: Wireless issue (AGAIN), Mageia 5

Postby dedanna1029 » 30 Mar 2016, 14:15

Yep, I saw it there. Thank you.

I'm sorry, I've been at hospital the last five days. I'll check this out soon as I can.
I'd rather be a free person who fears terrorists, than be a "safe" person who fears the government.
No gods, no masters.
"A druid is by nature anarchistic, that is, submits to no one."
http://uk.druidcollege.org/faqs.html

User avatar
dedanna1029
Sound-Berserk
Posts: 8483
Joined: 14 Mar 2010, 20:29
Contact:

Re: Wireless issue (AGAIN), Mageia 5

Postby dedanna1029 » 12 Jun 2016, 23:55

I ran the code - FINALLY.
Still no joy. :(
I haven't tried with all the drivers though, so...
This is with Mageia's stock broadcom-bca-config. I'm going to try moving on with the broadcom-ssb-config, and then the broadcom kernel. I don't know what else to do.
I'll also try with the HP file.

Edit: I get a hard lockdown of the computer when I try to install the broadcom kernel.
I'd rather be a free person who fears terrorists, than be a "safe" person who fears the government.
No gods, no masters.
"A druid is by nature anarchistic, that is, submits to no one."
http://uk.druidcollege.org/faqs.html

User avatar
dedanna1029
Sound-Berserk
Posts: 8483
Joined: 14 Mar 2010, 20:29
Contact:

Re: Wireless issue (AGAIN), Mageia 5

Postby dedanna1029 » 13 Jun 2016, 00:26

I also tried R_Head's line for shits 'n giggles.

I think I'll run "rfkill unblock all" for shits and giggles.
I'd rather be a free person who fears terrorists, than be a "safe" person who fears the government.
No gods, no masters.
"A druid is by nature anarchistic, that is, submits to no one."
http://uk.druidcollege.org/faqs.html

User avatar
R_Head
Berserk
Posts: 2566
Joined: 17 Mar 2010, 15:40

Re: Wireless issue (AGAIN), Mageia 5

Postby R_Head » 13 Jun 2016, 13:36

Do not poop yourself from giggling.... :lol:

User avatar
dedanna1029
Sound-Berserk
Posts: 8483
Joined: 14 Mar 2010, 20:29
Contact:

Re: Wireless issue (AGAIN), Mageia 5

Postby dedanna1029 » 17 Jun 2016, 22:41

rfkill unblock all had no effect at all. Nothing changed.
However, I've read that resetting the BIOS may do it?
I'd rather be a free person who fears terrorists, than be a "safe" person who fears the government.
No gods, no masters.
"A druid is by nature anarchistic, that is, submits to no one."
http://uk.druidcollege.org/faqs.html

User avatar
viking60
Über-Berserk
Posts: 9280
Joined: 14 Mar 2010, 16:34

Re: Wireless issue (AGAIN), Mageia 5

Postby viking60 » 17 Jun 2016, 23:07

I am not sure what code you have run?
Manjaro 64bit on the main box -Intel(R) Core(TM) i7 CPU 920 @ 2.67GHz and nVidia Corporation GT200b [GeForce GTX 275] (rev a1. + Centos on the server - Arch on the laptop.
"There are no stupid questions - Only stupid answers!"

User avatar
dedanna1029
Sound-Berserk
Posts: 8483
Joined: 14 Mar 2010, 20:29
Contact:

Re: Wireless issue (AGAIN), Mageia 5

Postby dedanna1029 » 27 Jun 2016, 18:23

a) I tried your code to blacklist

b) Tried R_Head's code at that thread just for shits 'n giggles

c) Tried "rfkill unblock all" which had no effect whatsoever - I'm still in the same state.

Please again, assume all has been run from su -

I'm wondering if I need to go through the steps on this page at 202. I'm sure debating trying them.

I'm still at hardblocked:yes in rfkill list all. I really don't know what else to do other than the steps at that link.
I'd rather be a free person who fears terrorists, than be a "safe" person who fears the government.
No gods, no masters.
"A druid is by nature anarchistic, that is, submits to no one."
http://uk.druidcollege.org/faqs.html


Return to “Help”