Page 1 of 1

Manjaro Mageia and Centos not booting in VM

Posted: 29 Jan 2016, 12:03
by viking60
I have this strange effect after an update on my Manjaro host.

When I fire up Virtualbox and start Debian, Zorin or Fedora - everything is fine.

When I try to start Mageia, Manjaro or Centos then I get "Failed to open Virtual machine"
The device helper structure version has changed.
If you have upgraded VirtualBox recently, please make sure you have terminated all VMs and upgraded any extension packs. If this error persists, try re-installing VirtualBox. (VERR_PDM_DEVHLPR3_VERSION_MISMATCH).

Result Code:
NS_ERROR_FAILURE (0x80004005)
IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Now reinstalling would make sense if all my clients were fubared but most of them work just fine - Even Windows XP!

I have tried to turn on and off 3D in the Display section without any luck.

The strange thing is that while standard Manjaro does not fire in Virtualbox; the openRC version does! That is the version without Systemd.

I am a bit puzzled by this.

Any tips?

Re: Manjaro Mageia and Centos not booting in VM  Topic is solved

Posted: 29 Jan 2016, 13:55
by viking60
Got it! :jackpot

The Virtual Machines do create Hard disks in the shape of .vdi files - like Mageia.vdi. I backed up this file and deleted the Mageia, Manjaro etc virtual machines.

Then I copied the backed up .vdi files back to ~/VirtualBox/HardDisks/ (It would be enough to simply renaming the .vdi before you delete the machine)
I then created new Machines in Virtualbox.
Now it was only a matter of pointing the newly created machine to Mageia.vdi and Manjaro.vdi etc.

Problem solved.

In the case of Centos it was another thing where the activated USB2 did not work so I simply disabled it in the VM settings - and everything works there too :smug
(Edit: In fact I could check the USB controllers again after this summersault)
Why this happened in the first place is still a mystery to me though. :confused

Re: Manjaro Mageia and Centos not booting in VM

Posted: 30 Jan 2016, 02:34
by dedanna1029
Wow. Good information there.
I would've said to go ahead and back up your virtual machines, then uninstall/reinstall vbox, but that would have probably been a very long way around.

Sometimes file corruptions can happen, or something conflicting, it could've been anything, really.

Re: Manjaro Mageia and Centos not booting in VM

Posted: 30 Jan 2016, 21:11
by viking60
I did reinstall Virtualbox but that had no effect on this. The strange thing is that half the VM's worked perfectly and the rest were fubared. :confused
I dunno why :confused

The virtual harddrives (files with .vdi extension) were OK too , and obviously creating a new Machine worked just fine.