Linux gaming

Moderators: b1o, jkerr82508

User avatar
Posts: 8612
Joined: 14 Mar 2010, 20:29


Postby dedanna1029 » 02 Nov 2015, 22:08

Yes, an old game but I still have yet to finish it.
Yes, I've bought it too.
It runs fine in Winders, but I'm having issues with the .rpm installation in Mageia, and I don't know why. Others I know run it just fine.
I get a Segmentation Fault on it when I try to start it from cli. According to MCC, with the exception of a very few files, the .rpm installs the game to /opt/Aquaria.

I tried the tar.gz, got a segfault with it as well when I tried to start it.
I tried the, got a segfault with it also when I tried to start it.
I tried the other two because with the .rpm installation, it would segfault when I tried to start it.

Clearly something is going on here, there is something I'm missing for it, or something.
I would think that where the arrow is, that would be the execution file:

Code: Select all

[dedanna@localhost Aquaria]$ ls
-->aquaria**    README-linux.txt
aquaria.png*   scripts/
config/*  sfx/
data/*   usersettings.xml
default-1.xml  maptemplates/     vox/
docs/          _mods/            xdg-open*
gfx/           mus/

If I remember correctly, when there is a star at the end of a file like there is on a few of the files in that output, it means something but I can't remember what. For now, when I try to start the game two different ways:

Code: Select all

[dedanna@localhost ~]$ /opt/Aquaria/aquaria
Segmentation fault
[dedanna@localhost ~]$


Code: Select all

[dedanna@localhost ~]$ cd /opt/Aquaria
[dedanna@localhost Aquaria]$
[dedanna@localhost Aquaria]$ aquaria
bash: aquaria: command not found
[dedanna@localhost Aquaria]$

... Something clearly isn't right.
Of course, I'm *assuming* that the file in /opt/Aquaria is the execution file.

Thanks for any input.
I'd rather be a free person who fears terrorists, than be a "safe" person who fears the government.
No gods, no masters.
"A druid is by nature anarchistic, that is, submits to no one."

Return to “Gaming”